Service Incident Notice

Incident Report for CryptoProcessing

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2026 - 14:03 UTC

Investigating

We are currently experiencing issues with Solana-related operations. Our team is actively assessing the situation, and we will provide an update as soon as more information becomes available.
Posted May 29, 2026 - 12:08 UTC
This incident affects: Transaction Processing (Deposits with exchange, Deposits w/o exchange, Withdrawals with exchange, Withdrawals w/o exchange, Exchanges, Invoices with exchange, Invoices w/o exchange).